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1. General 

 The process described depends partially on the probe firmware. This document was created with the ver-
sion V01.40 (004417.21). 

2. Licensing terms 
Below are the licensing terms for the calibration software nSoft-CAL.   The user accepts the following terms 
on installation: 

License 

 With the purchase of the software, the user acquires the license for the use of the calibration software 
nSoft-CAL.  The property and copyright remain at Novasina AG. 

Prohibited copying 

 The licensed programs as well as the documentation are not allowed to be copied, neither completely nor 
partially. The only exception is the creation of a program copy for data backup purposes. 

Prohibited alterations 

 The customer may not modify the program or allow it to be modified by third parties. 

Warranty 

 Novasina AG is not liable for loss of profit, damage or loss of stored data nor any other collateral damages 
caused by the use of nSoft-CAL. 

3. System requirements 
The calibration software nSoft-CAL runs on Windows operating systems such as XP/VISTA/7/8.  

4. Product description 
 This software is used to verify and calibrate Novasina  nSens-HT, nSens-T probes as well as  set parame-

ters of  the nSens-VAL simulator using the correspondent USB adapter. 

 The nSoft-CAL software allows also performing firmware updates. 

5. Installation 
 Insert the nSoft-CAL CD inside the CD drive and start Windows Explorer. Click on the corresponding drive. 

In the directory nSoft-CAL you can find the installation software nSoft-CAL_Cal_Installer_Net_VX.XX.exe 
Double-click to start the installation Wizard. 

Notice:  

For the first installation it is recommended to fully install the nSoft-CAL and then connect the nLink-USB cable 
to the PC. This avoids problems with the driver software installation. 

 

5. 1. Program setup 
 Please follow the instructions of the installation Wizard (setup program).  

 

6. Operation 

6. 1. Selection of USB adapter 
 Connect the USB adapter to the PC before you start the "nSensCal". 

 Select the USB adapter you need in the toolbar under "Adapter: ". 
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Notices: 

 Several USB-adapters can be connected. They are identified by the serial number mentioned on the type 
label. 

 The adapters are listed in order of serial nos. 

 If no adapters are shown, they are either not connected to the PC or the driver installation was not carried 
out correctly. 

6. 2. Window display overview 

 Measuring value display 6. 2. 1. 

 The actual measuring values are displayed on the 
left. 

 The information regarding the selected probe is 
displayed on the right.  

 If no probe is connected or in case of failure, 
warning triangles are displayed. 

 
Click on the triangle to display information on an 
existing failure or problem and to show solutions.  

 

Move to the calibration point display with , ,  

respectively with , ,  or by the menu points. 

 

 

 

 

 

 

 

 

 

 

 

 Calibration status display for probes with factory 6. 2. 2. 
calibration points 

 For new probes, the factory calibration status with 
date and originator name is shown. The single 
calibration points are not displayed but are shown 
on the Novasina factory calibration certificate re-
ceived with the probe. 

 This indication appears only if there are no User 
calibration points (see chapter 6.2.3). If such 
points exist, the factory calibration is overwritten. 
As soon as all user points are deleted, the factory 
calibration is restored. 

Note: the factory calibration can only be modified by No-
vasina. 

Return to measuring value display mode with  or [ESC] 
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 Calibration status display for probes with user 6. 2. 3. 
calibration points 

 Display of calibration points defined by the user. 
As soon as the first user calibration point is set, 
the Novasina factory calibration is overwritten. For 
calibration points corresponding to Novasina SAL-
SC humidity references, the description "Ref" is 
displayed. For freely defined calibration points, 
the description is "Usr" (see also chapter 7.3 pa-
ra.3) 

 All active points for this operation are listed on the 
left.  
Select one point to show detailed information: 

o Last changed:  
Date, time, at which point was calibrated. If the de-
vice on which the calibration was performed has no 
clock, no time information will be shown. 

o Instrument: 
Instrument or software, which carried out the cali-
bration. 

o Correction value: 
Correction value [%RH] related to the basic charac-
teristic curve. 

o Temperature: 
Temperature at which the calibration was carried 
out. 

Return to measuring value display mode with  or [ESC] 

 

 

 Display of sensor failures 6. 2. 4. 

Access with  on measuring value display 

 After the proposed solution, information for the 
Novasina support service are shown. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 About 6. 2. 5. 

Access with "Help->About" 

 Version display of the main application as well as 
the communication - Dll.  
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6. 3. Menu items overview 

Menu Item Icon Function 
File->Exit  Quit the program 
Sensor->CalHumidity or  
Sensor->CalTemperature 
->Info calibration points... 

 

 

 
 

Calibration points display  
 For factory calibrated probes, no calibration 

points are displayed but the confirmation of a 
performed factory calibration incl. date and orig-
inator. The calibration points are shown on the 
corresponding probe’s factory calibration certifi-
cate (see chapter 6.2.2) 

 
 As soon as a User Calibration is carried out, on-

ly the user calibration points are displayed (see 
chapter 6.2.3) 

 
Sensor->CalHumidity or  
Sensor->CalTemperature... 
->Calibrate 

 

 

 
 

Carrying out the calibration 

Sensor->CalHumidity or  
Sensor->CalTemperature... 
->Clear calibration points... 

 

 

 
 

Deletion of calibration points 

Sensor->Change password...  

 
 

Change sensor password 

Settings->Unit temperature  Temperature unit (°C or °F) setting 
 

Sensor->Simulation Values…  Fixed values settings for  rel.humidity and temperature 
for nSens-VAL-HT simulators. This function is only acti-
vated and visible if a nSens-VAL-HT simulator is con-
nected. 
 

Tools->Firmware update…  
 
 

Firmware updates for probe type 
 nSens-HT-Exx 
 nSens-T-Nxx 
 nSens-VAL 

 

7. Carrying out the humidity calibration 

7. 1. Fundamentals 
 Theoretically up to 13 humidity and 2 temperature points can be calibrated.  

 The humidity calibration can be performed either using a Novasina SAL-SC salt reference (recommended) 
or with any other reference (this is a new feature compared with previous Novasina instruments).  

 The highest accuracy is achieved with a so-called "Bracket Calibration", where the calibration is carried out 
around the effective measuring range. For example using Novasina salt references and calibrate the next 
higher and next lower humidity point. Since only these 2 calibration points are influencing the accuracy it is 
not necessary to calibrate any other point outside the measuring range.  
Example: The effective sensor working range in the field is between 35%RH and 45%RH -> the recom-
mended "Bracket Calibration" should be done at 33%RH (with SAL-SC 33) and 53%RH (with SAL-SC 53). 

 The software shows the following message if the recommended salt reference temperature range is not 
kept.  

 
Reason: outside of this range the references can only be used with profound specific knowledge. 
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 The temperature dependency of Novasina salt references is compensated automatically with the tempera-

ture shown by the probe to be calibrated.  
If this is not possible because of the temperature, the related salt calibration is blocked.  

 

 

7. 2. Deletion of calibration points 
 The deletion of calibration points causes a reset to Novasina factory calibration status.  

This function is new since, with previous Novasina instruments, the reset was done to the basic character-
istic curve. 

 For new calibrations it is recommended to delete the calibration points, where no reference is available.  
Principle: a deleted calibration point is normally better than an incorrect calibration point since deleted 
points are extrapolated by adjacent points. 

 Procedure  7. 2. 1. 

 

1. Select "Sensor->Cal. humidity->Clear calibration points..." or 

press . 

2. Select the point to be deleted and press [Clear]. 

3. If the probe is password protected, the password is request-
ed, otherwise answer the question "Are you sure to..." with 
[Yes]. 

Tip: 
With [Clear all] all points can be deleted at once. 
 

7. 3. Humidity calibration (User Calibration) 

 

1. Expose the probe for a sufficient time to the humidity refer-
ence. Ensure also that the temperature adapts to the refer-
ence.  

2. Select "Sensor->Cal. humidity->Calibrate..." or press  

3. The recommended calibration point is now shown in bold on 
the left screen side and is already selected.  
Check in any case if the selected point matches with your 
reference, otherwise correct the selection.  
(Usr = User reference, Ref = SAL-SC reference).  

4. Select [Calibrate selected point] to adjust the selected point.  
Alternatively you can define a new specific user point with [New user reference point] in case you are not 
using Novasina SAL-SC references. 
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5. If the point to be calibrated concerns a user reference, you will be asked for the reference humidity 

 
6. Press [Yes] to complete the calibration  

If the probe is password protected you will be asked for the password. 

 

Notice:  

 As soon as the first point of a user calibration is calibrated, the Novasina factory calibration is overridden. 
As from this moment the user calibration points are displayed (see chapter 6.2.2. and 6.2.3.). 

 The factory calibration is restored as soon as all user calibration points are deleted. 

 The factory calibration can only be modified by Novasina. 
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 Specific messages during calibration 7. 3. 1. 

 

After switching to the calibration display mode, the calibration 
must be completed within the indicated time.  
Press [Yes] to read-out the probe and solve the problem.  
Reasons: 
The required values for calibration are displayed after switch-
ing to the calibration display mode. If the elapsed time is too 
long, the values may be invalid. 

 

The measuring value differs too much from the reference 
value 

 Check if the user reference value was set correctly. 
 If the reference is correct, the probe might be dam-

aged or the drift is too great.  

 

The selected calibration point is too near to another already 
calibrated point. 

 Press [Yes] to delete the selected calibration point 
and cancel the calibration. 

 

FoldError. 
 This problem occurs if incorrect nominal value and 

measured value pairs are defined. 
 In such cases the best solution is to delete all calibra-

tion points and to repeat the calibration with well-
maintained references. 

 All calibration points are taken 
 for the nSoft-CAL up to max. 13 humidity and 2 tem-

perature calibration points are available. 
Delete an unused calibration point to free storage 
space. 

The set password is incorrect.  
 Enter the correct password and press [OK].  
 Note: 

A forgotten password can be only reset by Novasina.  
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8. Temperature calibration 

 Normally the temperature measurement must not be calibrated during the lifetime of the probe. 

 In the case that the probe requires calibrating with a specific reference you can follow the following proce-
dure: 

1. Expose the probe to the required temperature environment. 
Important:  
Humidity probes must not be dipped in a liquid. 

2. Select "Sensor->Cal. temperature->Calibrate..." or press . 

3. Press [New user reference point] to create a calibration point or select a previously calibrated point for the 
recalibration. 

4. This procedure is the same as for the humidity calibration (see chapter 7. 3).  

 

9. Password protection for calibration values 
 The calibration points can be protected by password against accidental changes. In the case of simulators 

such as nSens-VAL-HT with firmware 01.40 onwards, the set simulation values are also password pro-
tected.  

 The maximum password length is 12 characters and is case sensitive.  

 If the probes are calibrated on devices with only numeric input option, the password should be set in the 
range of 0001 .. 9999.  

 Important:  
There is no possibility to reset a password by the user!  
A forgotten password can be only be reset by Novasina on a specific inspection system.  
Hence use the password with caution.  

9. 1. Password handling 

 Procedure to set or change password 9. 1. 1. 

 
  

 

1. Select "Sensor->Change password..." or press  
 

 2. Enter the required password in "New password". 
If a password is already defined, the additional input 
field "Old password" appears, in which you should en-
ter the previous password. 

 
3. In case the password is out of the range of 0001 .. 

9999, a warning that it cannot be used for any No-
vasina devices is displayed. 
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 4. Re-enter the new password in the window "Please re-

enter the new password". 
With this replication typo errors should be avoided.  

 
5. The password change is confirmed as shown on the 

left. 

 Procedure to delete password 9. 1. 2. 

 
  The password deletion is similar as described under 

chapter  9. 1. 1.  however the input field "New pass-
word" is left empty.  

 The deletion process is confirmed with the message 
as shown on the left. 

10. Setting parameters of nSens-VAL simulators 
 The nSoft-CAL software also allows settings on nSens-VAL simulators for the output of fixed measuring 

values.  

 Such simulators are normally used for the validation of measurement and control processes.  

10. 1. Procedure 
 
  

 

1. Select " Sensor->Simulation Values…" or press 
 

Notice: 

The icon           is only shown if an nSens-VAL-HT is connected. 

 

2. Select the probe type you want to simulate: nSens-HT for a com-
bined probe for humidity/temperature, or nSens-T for a tempera-
ture probe. 

 

 

3. Enter the required fixed values of the corresponding measuring 
parameter (%RH for humidity / °C for temperature). 

4. Confirm with [OK]. 
 

Notice: 
With [Cancel] you can quit this function menu. 
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11. Carrying out firmware updates 

 The nSoft-CAL software allows a probe firmware update using the firmware update  function. The firmware 
data files are available on request from Novasina.  

11. 1. Procedure 
 
 1. Select " Tools->Firmware update… 

 

 

2. The firmware selection window appears. 

 

 

3. Select the corresponding update software file and press             
[>> (proceed)] 

 
 

  

 

 

 

4. Start the update with [Start device programming]  

 
 
 
 
 

  

 

 

5. The firmware is updated 
 
 
 
 
 
 

  
6. The firmware was installed successfully. To complete and exit the 

installation procedure press [Ok] 
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